Exim4 and PHP and PHP-CGI mail() function using incorrect From: and applying Sender: headers.

If you’re using Exim4 and PHP as a module or as a CGI with suexec. You may have noticed some issues with your mail. Specifically you would have noticed that either the “From:” header was using “nobody@machinename” or “user@machine name, its also possibly that you had an additional header called “Sender:”. There are two things you need to do to fix this. You first need to make sure that your “php.ini” has the following value “sendmail_path = /usr/sbin/sendmail -t -i”. Which is the default, double check this variable as it might be set to something else.

If you’re using Exim4 and PHP as a module or as a CGI with suexec. You may have noticed some issues with your mail. Specifically you would have noticed that either the “From:” header was using “nobody@machinename” or “user@machine name, its also possibly that you had an additional header called “Sender:”.

There are two things you need to do to fix this. You first need to make sure that your “php.ini” has the following value “sendmail_path = /usr/sbin/sendmail -t -i”. Which is the default, double check this variable as it might be set to something else.

Next you want to make sure that you have Exim4 configued properly, if you use Debian Etch then you should be fine. However if you change the default configs or have a different setup. Then make sure you have set “local_from_check = false” inside “exim4.conf.template” for Debian Etch and if you don’t use Debian then check the exim configs.

0 Shares:
You May Also Like