Setting up MikroTik/RouterOS with Conditional DNS Forwarding (UnoTelly/UnblockUS)

I have a MikroTik RouterOS device that has some custom DNS settings and therefore I cannot change the DNS servers it provides to clients, which is a requirement to use UnoTelly or Unblockus. Instead I found the following article very helpful, it allows you to configure Conditional DNS forwarding for specific domains.

https://www.dalemacartney.com/2012/12/29/dns-conditional-forwarders-with-mikrotik-routeros/

This works well because I use MediaHint to swap back and forth for NetFlix US and Canada, but use only the US Amazon Prime.

/ip firewall layer7-protocol add name=domain.com regexp=domain.com
/ip firewall mangle add chain=prerouting dst-address=<routeripaddress> layer7-protocol=domain.com action=mark-connection new-connection-mark=domain.com-forward protocol=tcp dst-port=53
/ip firewall mangle add chain=prerouting dst-address=<routeripaddress> layer7-protocol=domain.com action=mark-connection new-connection-mark=domain.com-forward protocol=udp dst-port=53
/ip firewall nat add action=dst-nat chain=dstnat connection-mark=domain.com-forward to-addresses=<UnoTellyDNSServerIPAddress>
/ip firewall nat add action=masquerade chain=srcnat connection-mark=domain.com-forward

 

1 Shares:
You May Also Like

MySQL and OpenSSL Replication what a mess!

Just a heads up, if you do decide to enable OpenSSL so you can do encrypted MySQL replication. There are two bugs that will affect replication and the mysqldump command. They're as follows: Bug #24148 regression tests hang with SSL enabled http://bugs.mysql.com/bug.php?id=24148 http://lists.mysql.com/commits/17286 Bug #27669 mysqldump: Got error: 2026: SSL connection error when trying to connect http://bugs.mysql.com/bug.php?id=27669 http://lists.mysql.com/commits/24329 This may cause lots of problems with MySQL and SSL Replication using OpenSSL. Cheers!

Linux computer that takes only 8 watts of power and can be solar powered

I know everyone is loving the new Asus Eee PC and they should, its a wonderful device. But if you want to go even smaller you can take a look at Aleutia E1 it only takes 8 watts of power and can be charged using solar power. Definitely for the out and out and about type traveler that needs a small computer that can be charged easily, combined with a sattlite phone for data and you have all that you need in a remote location.

iriver’s UNIT2 detailed on teaser site

One of the sexist and functional MP3 devices I've seen yet. The iPod had its time, and even the smallest iPod is really sexy. But this is just over the top.
iriver's UNIT2 detailed on teaser site -

Filed under: , ,


Mmm, there's nothing like fragmented high-resolution photos of a lust-worthy device to get us salivating, and iriver's marketing department has done an exquisite job figuring that out. Shortly after unveiling the sexiest e-dictionary known to man, the much anticipated UNIT2 conglomerate received its own teaser site, complete with photos and a few extra details you should know. While it has yet to lose its mystique, we now know (officially, at least) that the base will act as a DVD player, TV tuner, access point, charging station, hard drive, and a speaker station. Aside from sporting an SD slot and USB connectivity, this beauty will handle music, movies, photos, eBooks, and WiFi streaming without breaking a sweat. Mechanically, you can expect an automatic sliding door, detachable display, slot-loaded CD / DVD deck, and a 78-key controller to manage the fun. No word yet on the price, but be sure to peek the additional photos below.

 

Read | Permalink | Email this | Comments


Office Depot Featured Gadget: Xbox 360 Platinum System Packs the power to bring games to life!

[EnGadget]

Corporate critics feel the stinging lash of DMCA misuse

I use to work for an ISP and was head of the Abuse Department. We only really received legitimate DCMA's that were then handled by legal. We didn't really seem to get that many DMCA notices, maybe its because we're a Canadian organization?
Corporate critics feel the stinging lash of DMCA misuse -

Two recent cases show that companies aren't always fans of criticism, and some will file misguided DMCA notices and defamation cases to scrub it from the Internet.

Read More...